Voicemeeter / Device changer not work

Problem description:
Your problem description here, as much details as possible
Settings device changer select device i want… no sound then spotify says unable to play song after a bit
also if wont remember the device i select after restart
Operating system:
windows 8

onboard realtek / voicemeeter

Spotify version
You will find the version info in the Help->About menu

Equalify Pro version
You will find the version info in Settings->About

Any special software or hardware you might have installed:
ie. Razer Gamebooster or Cortex

There are no issues with realtek or voicemeter that i know of.
What is the name of the device you are switching to ?

There’s probably thousands of people using the device changer with a realtek onboard soundcard and VAC or voicemeter so it should work just fine.

For the not remembering the device - Have you made sure you ticked the “Make the device selection permanent” before hitting apply ?

ive done that

the default device works and is the one it always switches to
the other one doesnt and is my perfered device

none of the devices other than defaut work

The can’t play song I thought was from region locked songs have you tried to play a different song?

that has nothing to do with it @DigidyDOG … something else is at play here :stuck_out_tongue:
investingating as we speak

@Chewychunga could you also share a screenshot of your voicemeter (banana) settings ?

I’m playing music in spotify, through a realtek soundcard and through voicemeter now without any apparent issues.

I do not have the CABLE-A and CABLE-B devices though, i only get the voicemeeter VAIO and AUX VAIO devices.

Cable - A and B are from http://vb-audio.pagesperso-orange.fr/Cable/VirtualCables.htm
its not just thoes cables tho… i have this problem with ANY device other than default

lets first try changing the default output of voicemeeter from the kave headset as that has a builtin soundcard as well. set it to some default speaker out.

Remember to restart spotify between everything you change/test.

If that doesn’t help try shutting down voicemeeter, and you can also try just unplugging the kave headset.
Still remember to restart spotify between each change.

Its a process of elimination. There has to be something on your system that’s not playing ball with the device changer, and we have to find it

In your default output’s

Have you selected the WDM or MME version of the devices ?

i think i can replicate some of what you are describing if i use the WDM devices, but it works fine with the MME devices.

if i do this (set all output devices to use the MME versions)

all output devices will work fine in the equalify device changer.

If i use the WDM versions, i will only be able to play music through the VAIO and AUX VAIO devices in spotify.
The other devices will show the “cant play this track” bar and no sound.

It could still be an issue with the headset though. But this is worth a shot.

i have wdm version and ive tried the mme
also tried to change the kave and still error
sound works for everything elser fine

Unplug kave, and set all 3 of the outputs to use the mme versions of the outputs.
Then restart spotify and test.

nope… its changed it back to default not the one i selected

care to use teamviewer and take a look yourself?

Are you able to use it the way you want now ?

And was it the kave headset or the MME that helped ?
If its the MME i can write up a little guide if someone has the same issues in the future.
If its the kave i’ll have to add it to the incompatible HW list.

yea i could do that, send me a private message with the id and pass

FIXED! KS and other done seem to work
Great customewr support!!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.