Spotify Version breaks equalify

Dear Support team and community,

I installed the standalone version; I kicked out the Windows 10 Store version right at the very beginning…
Then I installed equalify pro onto version 1.1.43 something…

At some point after a restart, even after running through the PowerShell scripts, restarting Spotify invokes the installer and the latest version, currently, gets installed. This version is destroying equalify pro it would appear. I don’t see the bars fully, they are greyed out and you cannot klick on the button in Spotify to make the equalify pro window appear… whatever I do, the only way to regain functionality is to reinstall everything, but within minutes, Spotify updates itself to this 1.1.44 version and kills equalify pro again…

Any ideas?

Thanks in advance for your assistance


PS: Nothing has changed on the system, just the version of spotify… it was working perfectly well until the version update


What bars is it that you can not see? The button in the top right?

There should not be any problems with 1.1.44.x.
Here is a screenshot from my machine just now:

There is no reason to do anything in the Spotify Windows Store removal guide if you do not have the store version installed.

Thanks for that…
When the spotify window is maximised, the bars are in a greyed box. Clicking on them has no effect… i.e. the equalify window does not open.

It was working in version 1.1.43, the update to 1.1.44 has somehow killed it…



In a smaller window, the bars still look as they do in your screenshot, though there is no function to the button…

Here is a screenshot with my version number visible… the button is not in the same location…


Try this:

  • Shut down spotify (file->exit)
  • open %appdata%/equalify in the file explorer
  • Back up and remove the equalify2.eq file (just copy it to some other folder before deleting)
  • restart spotify and play a track

Just tried that and no change. The button reappears in the false location and will not open when clicked…


PS: Thank you for assisting :slight_smile:

Shut down spotify agai.
open your equalify2.eq file in a text editor
find “DPI”
set it like this: "DPI": 192,
find “dpiscalemainbutton”
and set it to this : "dpiscalemainbutton": 1

Also please tell me what was there before changing the values.

I just removed equalify, spotify, and then reinstalled both. I deactivated the equalify licence after it was removed, so I could reactivate equalify.
The button still appears in the wrong place and the equalizer cannot be configured.
Just to let you know of additional measures I have already tried…

The equalify.eq file is completely empty… 0Kb in size, nothing to edit…


what does the old file that you backed up contain ?

I thought of that also after your post…

“DPI”: -1,

dpiscalemainbutton was already set to 1


Put that file back and set dpi to 192
and lets see what happens…

Did that already…
The button is just larger in size, but the same problem, in a grey box when the window is maximised and without all function…


picture please



It works fine on my system with version 1.1.43.x
Something in spotify has changed with version 1.1.44.x that is affecting the use of the plugin on my system.

I am running Windows 10 Build 1909, I have not updated to 2004 on this box, as there were some possible issues for me (as I use this as my home office device)


At the start it looked like it couldn’t automatically detect the correct scaling, but even with manually changing the scaling it does not seem to work properly. 192 is too big, but that doesn’t matter.

You can try setting your monitor scaling to 100% instead of 125% or 150%

I have not seen that behavior before, so I’m really not sure what to try next. I’m fairly sure it has nothing to do with the Spotify update though, most people should be using the same update and only one reported issue. So it has to be something with your machine.

What windows update you are on should not matter at all either.

Have you tried just rebooting the system completely ?

The monitor scaling is already at 100%, I run on a 27-inch fullHD monitor, so no problems with font sizing or scaling…
Rebooted a few times earlier before I contacted the community…

Need to hit the sack now… long day tomorrow…

EDIT: I have now rolled back to 1.1.43. and have changed the setting to stop Spotify autoupdating to a new version without consent. Unfortunately, that appeared to be arbitrary last night, as it updated regardless of that setting…

Adding in my 2¢ - I’ve just been updated to this same Spotify version and have the same issue.
Right-clicking the icon brings up the context menu, where the only item is “Reset EQ position” but it’s also greyed-out.

Same thing started happening to me today…tried all the fixes suggested…nothing worked. This is happening on two different systems and began in the last two days.

I do not have anything new to come with, but just wanted to let you know that i’ve seen your posts.

As soon as i am able to replicate the issue on any of my machines i’ll be able to understand the problem better and create a fix. But until then there is unfortunately not a lot i can do.

I do not have this issue on any of my machines.

I might be able to create an alternate way to open the EQ while this issue lasts.

In the meantime, can you guys share some info about your computers.

  • OS
  • processor
  • gfx card
  • gfx driver version
  • any special software
  • anything that could be interesting

If we see some similarities it could be easier to track down what causes it.