Qualiy button does not show up

Problem description:
I installed and used Equalify yesterday in my Spotify (Desktop Version, not the Win Store). Now today I stared my PC and loaded Spotify and played a song but the button simply will not show up. Not matter what I do… Reinstalled both (spotify and equalify), restarted my PC etc. but nothing works. Need Help!!

Operating system:
Win10

Soundcard:
Soundblaster Z

Spotify version
1.0.86.337.ga8d5cef9

Equalify Pro version
1.4.3 (latest), downloaded yesterday

Any special software or hardware you might have installed:
None

If it worked yesterday, it should work fine today as well.

Play a song and mouse over the area where the button was yesterday, maybe it just needs a little nudge to show up.

:D:D Really?? No it does not work! Even if I mouse over it several times while playing music! The error still exists!
http://prntscr.com/kg1tjg See? I moused over it several times!

So no further high-quality suggestions?

If you only knew how many support tickets has been solved by asking the user to just play a track, you’d understand why that was asked first…

First we have to find out what has changed since yesterday. I mean, if it loaded fine yesterday there is no reason at all for it not to load today. Unless something has changed on your system.

Did you install any new software, or hardware? Connect any wireless speakers or headphones?

As far as i can see it looks like its loading on your machine. The last key validation for your account was done at 10:18am (30min ago).

So i’m not sure whats going on. I’d need some more info before i can give any further advice.

ps:
You sound a little passive-aggressive there my friend. No need for that, i cant be here 24/7 :slight_smile:

Sorry for the aggressiv wording but I was a little stunned by the “mouse over”.

Not, I diid not change any hard- or software. I shut the PC down normally yesterday evening and today the button simply won’t show up. No changes etc. have been made in the night. Also have the speakers been connected identiically all the time.

So my system hasn’t changed at all.

The mouse over suggestion was because sometimes Spotify forcefully overwrites the button graphics (making it look like the EQ is not loaded), mousing over will then make it re-appear. So it was actually a valid suggestion even if it looked like a joke.

The strange thing is that it appears to be loaded. Because its doing the update checks, which it will only do if… its loaded…

Checking the logs for your IP says that you last started Spotify with Equalify installed and loaded at 10:18am, and its been running until at least 11:18am since it did another update check at that time.

I can not understand why it would be loaded and doing update checks and not show in the Spotify window. It shouldnt be possible.

Could shut down spotify (file->exit, do not use the [x])
then go to %appdata%/equalify and delete equalify.dat (and equalify2.eq if you have no custom presets saved)

Then restart Spotify and see if it asks you to log back in to Equalify.

Unfortunately this also does not help.


I deleted the two files and proceeded just as you said.

Try restarting Spotify now. i reset your account on the server side.

I have no clue why but right now it seems to be working… I’
ll restart my PC now and see if it still works after my restart. Unforunately my EQ settings are gone now but OK I think I can restore them.

if you want to restrore your custom settings, you can restore the equalify2.eq file ffrom the recycle bin.
Do not restore the equalify.dat file though.

This seems to be exactly what causes the crash/disappearing of the button. It seems to work out so far now.

"This seems to be exactly what causes the crash/disappearing of the button"
What is “this”?

Restoring the equalify2.eq file ?

If so, please send me the file so i can do some testing.

YSes, exactly. Once I copy the “old” .eq file into the folder oyu showed me the button disappears.
How can I send you this file? E-Mail address?

[email-removed-so-spambots-cant-find-it] or https://send.firefox.com/

Thank you, i can not see anything obvious wrong with it, but testing confirms that something in it makes the EQ button not show up. Will update you once i figure out what :slight_smile:

Ok i know what the problem is.

The EQ actually loaded fine but the EQ button was not visible due to you enabling 200% scaling and a bug that allowed the button to be drawn outside the allowed render area - if the Spotify window was not scaled as well.

I’m fairly sure i’ve tested this exact use case before to make sure it worked. So i must have managed to break it in one of the last couple of updates.

1 Like

Yeah this is very likely to be the case because I worked on the EQ in WQHD on almost fullscreen and Spotify was running in FHD on the 2nd screen. So I drastically enlarged the picture with free sclaing.
Sounds like a valid reason if you ask me.

So hope you get this fixed with the new release. So far I f*king love this piece of software beacuse I can finaly compensate my shitty room and setup at 33, 66 and ~128 Hz (standing wave).
Another input: Maybe you should make it possible to export and import the selfmade EQ settings and not just copy them into clipboard.
Cheers!

I already have a fix for the problem, 200% scaled EQ button in a non-scaled Spotify window is not pretty though.
But it will at least make sure the user will always have access to the EQ button so they can turn the button scaling off.
If you only want to scale the EQ and not the button, you should untick the “DPI scale the button in the spotify window”.

The exported/copied to clipboard settings are also importable, as long as the string is in the clipboard when you hit import it will ask you for a name and save it. It was meant to be temporary… but there is nothing more permanent than temporary solutions…

1 Like