Laggy Spotify performance with Equalify Pro

Problem description:
It’s a bit tricky to describe this problem appropriately, but basically it comes down to laggy Spotify GUI performance when using Equalify Pro. What I mean by laggy GUI performance is that Spotify is slow to browse and navigate when EQ Pro is installed.

Examples:

  • There’s a noticeable lag when maximizing the Spotify window to fit full screen and the other way round as well. Also, there’s a lag when opening the Spotify window when it’s minimized to tray bar. By saying lag, I mean it takes about 3 seconds before GUI starts responding and it allows you to navigate.

  • There’s a noticeable lag when scrolling the Spotify main pane (artist pages, playlist pages, basically anything).

None of this is happening when Equalify Pro is uninstalled and when I’m running only Spotify. Obviously I would love to keep using the plugin because it does a fantastic job sound-wise, but the lag issue is a bit of an annoyance.

I’ve searched the forums but didn’t really come across anything similar that’s been described before. Does anyone have any suggestions for troubleshooting this please?

If you need any more details, please feel free to ask and I’ll be happy to provide more info on this.

Operating system:
Windows 10 Home, x64

Soundcard:
IDT High Definition Audio Codec (that’s what it comes up as in Device Manager)

Spotify version
1.0.45.186.g3b5036d6

Equalify Pro version
1.1.5.3023 (master:9d66d3d)

Any special software or hardware you might have installed:
None

OK - just a few minutes after I posted this, I’ve managed to find a fix for this issue.

Basically, I’ve just disabled hardware acceleration and Spotify performance is back to normal - no lag whatsoever.

What I had done in the past in order to troubleshoot this was reinstall both Spotify and Equalify, and also clean the cache folder - none of that helped.

Guess it might be worth bringing this to your attention anyway, in case you wanna look into this with future Equalify builds.

Hey @wojciechk87.

Thanks for the detailed report and the “solution”. I’m sure that will help anyone that might encounter this in the future.

If you could provide a little more information about your computer that would help with trying to narrow down what could cause this.

  • CPU
  • GPU(s)
  • Antivirus(Eset nod32?)

And if you could re-enable hardware acceleration, with equalify installed, and run spotify.
Then open task manager->details and sort by most cpu usage and watch task manager while resizing and doing things in spotify and see if any program other than spotify uses a lot of cpu power.

But in general i know that spotify has some issues with how their hardware acceleration works. Disabling it is one of their “go-to” solutions for just about any issue. BUT… Equalify should not cause laggyness, and theres not been more than a couple of reports of this happening out of the tens of thousands of users we have, so its most likely just a super unlucky combo of hardware/software/settings.
I’d love to get to the bottom of it though, so any and all info you could provide will be helpful.

Hi @Notrace

Thanks for your prompt reply.

Happy to help you get to the bottom of this, especially that the fix I applied is more of a workaround than a proper solution.

The info you requested:

  • CPU: Intel Core i7-3630QM @ 2.40 Ghz
  • GPUs: NVIDIA GeForce GT 650M and Intel HD Graphics 4000
    A quick note here: I’ve tried running Spotify with each of these GPUs (right-click > Run with graphics processor) but it doesn’t seem to make a difference.
  • Antivirus: ESET NOD32 indeed (ver. 9.0.408.0) - has that proven to be troublesome in the past?

I’ve followed your suggestion, re-enabled hardware acceleration and ran Spotify with Equalify installed. As soon as I start doing anything in Spotify, ESET Service comes on top of CPU usage list in Task Manager. So I think you’ve nailed it:

Obviously, this doesn’t happen when hardware acceleration is disabled.

I’ve tried a couple of things like pausing protection in ESET or adding the Spotify folder to exclusions list, but no joy so far.

Another thing worth noting is that laggy performance occurs only when music is playing in Spotify. All good and no lag when music is paused.

Hey again

I wish everyone posted the way you do!

My hunch was validated. Seems like NOD32 is the common denominator.

In the previous report of the lag we saw the exact same thing happening. In that users case it was solved by doing a definition file update in NOD32 so i figured it was just one flawed definition file, but it looks like there is a deeper issue.

Last time i had no luck replicating it but i will make another attempt on the test machines.
If i cant replicate it, and work around whatever is causing NOD32 to misbehave, i will have to try to contact ESET and have them look at the issue, but dealing with AV companies has a tendency to take a lot of time…

Could you also try to download and install the previous version of equalify and see if NOD32 behaves the same way with that version installed.

Also, you say it only happens when music is playing. Does showing/hiding the EQ window change anything ?

Download: Equalify Pro 1.1.3b

Managed to replicate the issue easily this time.

From initial testing it seems like its NOD32’s “Advanced memory scanner” under the “HIPS” settings that is causing the slowdown. At least on my test machine disabling it made Spotify & Equalify work as they should without the ESET service slowing things down.

Any chance you can test and verify this? (disable and hit ok)

Hi again,

As for showing/hiding the EQ window, that doesn’t change anything and Spotify lags anyway when hardware acceleration is on.

I haven’t tested the previous version of Equalify now since you crossed it out, but I am pretty positive the issue was there with 1.1.3 as well - I have only updated mine to 1.1.5 not long ago and the issue has been ongoing for much longer. I can still rollback to an older version and test it if that’s helpful.

Now, as for testing your solution - worked like a charm! As soon as I’ve disabled Advanced Memory Scanner, lag has disappeared as well.

What I’ve also found is that you can keep Advanced Memory Scanner on and add a rule to exclude Spotify from being monitored by it.

Just point the rule to Spotify folder in your AppData directory and just enabling Operations affecting Applications is enough to do the trick - lag disappears:

Thanks for your help with finding a permanent fix for this @Notrace, really appreciate the support and all the good work that goes into improving Equalify!

1 Like

Then there is no more doubt, HIPS/AMS is doing something it shouldn’t.
I will try to contact ESET in the new year and see if there is something they can do about it as this is obviously a bug.
Meanwhile adding a rule to exclude Spotify from the scan will be the best option.

I suggested to disable the Advanced Memory Scanner as a test because that was more “bulletproof” and had less steps than adding a rule. If that worked for you i was going to suggest adding the rule to exclude Spotify from the HIPS scanning, but you beat me to it :slight_smile:


If its OK for you i want to copy some(a lot) of your text and images and make a post in the Known Issues category to make it easier for others to find if they happen to experience the same issue.

Cool, so we figured it out in the end - hopefully that will help if anyone else is experiencing the same issue. It will also be interesting to see if ESET can do anything about this.

As for making a post in the Known Issues category - absolutely, feel free to copy my text and images :slight_smile:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.