Equalify not working after latest Spotify update

Problem description:
Spotify doesn’t show the Equalify button after the newest update.

Operating system:
windows 10

Spotify version
Spotify for Windows

Equalify Pro version
1.4.11 basing this off of the Installer file, as I can’t view Equalify normally

Same issue.

Spotify for Windows

Latest EQP (1.4.11).

Spotify does show the EQP icon but when I click on it nothing happens.

@PureFred Make sure you restart Spotify properly and play music for Equalify to show the button.
Restart Spotify by going to the file menu and hitting exit, do not use the X in the top right corner.
There has not been any changes to Spotify that would make Equalify stop working. And i can confirm that it works fine on Spotify 1.2.9.x and 1.2.10.x.

@rfsanders Click the button normally once, then right click it and hit the “reset eq position” menu item that pops up. The eq should show up in the top left corner of Spotify.

1 Like

Hi, I have followed your steps, no change. I have had a full UI change, and no more button. I have done a clean reinstall of windows, both equalify and spotify freshly downloaded.


This is what I see. No EQ bars

spotify version - Spotify for Windows

Hey there, i’m sorry to hear that.

Yea, there are 2 spotify UI’s in the wild at the moment, and the Equalify button does show in both of them, in the correct spot. I’ve verified them both.

Here is the Equalify version that i just installed from the website - running in the latest spotify version, same as you have.

As i said - as far as i know - there has not been any changes to spotify that would make Equalify suddenly stop working.

Are you outputting audio through the same way you always have?
Did you install any new audio related software? (virtual audio cables, voicemeeter, ++)
Did you get new usb headphones or play music through bluetooth?
Are you using Spotify Connect to play audio on another device?
Did you upgrade/change your hardware or OS?

You could also try this version of Equalify: https://www.equalify.me/dl/Equalify1.4.13-installer.exe

Hi there, so no, nothing has changed. Everything remained the same until Spotify updated and the button just vanished!

Last night, I wiped and reinstalled Equalify again, but no luck. Is there anyway I can confirm Equalify is installing into the right area? It goes to AppData/Roaming/Spotify, and once the installation finishes, it auto closes Spotify, so I think it’s installing correctly?

Apart from that, the output hasn’t changed. I used to have a virtual audio cable, but it would be disabled, and never used. Same old headphones, no Spotify connect and the hardware remains the same apart from basic Windows 10 updates.

I tried the 1.4.13 and also no luck. I have a feeling my Spotify may be installed elsewhere, but I can’t confirm. I don’t see it in my Program Files or PF x86 either.


%appdata%/spotify is the correct folder. You can check that there is a file called dsound.dll in that folder. If its there, equalify is installed and should load when you play music.

You can also go to %appdata%/equalify and check that there is a file named equalify2.eq and equalify.dat

You can try closing spotify (file->exit), then deleting those files. Back them up somewhere else first if you want to keep any presets/settings you have saved.

Then try restarting spotify and playing music.

You could also try changing your windows default audio out to another device (speakers/headphones/??) before starting spotify and playing music.

PS: There is no need to look for the dsound.dll file in other locations, it will be in several other folders and not part of equalify. Its a windows systemfile. So do not delete it from anywhere else!

Hi again, I have verified everything, and still no luck! Every file you said was there in the correct location.

I have tried to exit Spotify, then delete the two files, and play music. The files didn’t re-appear after playing music.

All my outputs are disabled except the headphones I use. I disabled them and tried other ones, but no change.

After I deleted the two files, the equalify2.eq and the equalify.dat.

I also tried to delete the dsound.dll from the Spotify folder, but again no luck, so I brought it back.

Still no luck. This is very strange. I could reinstall spotify? Thanks.

Are those the only files in the spotify folder ? If so, your spotify is installed elsewhere.
Are you sure you are not using the windows store version of spotify? you can check by going to the help->about menu and it should say windows store after the version number.

If you have the windows store version you can try following the instructions here: Spotify Windows Store removal

Those are the only files, yes. I installed Spotify from the website, it says “Spotify for Windows”

Would you recommend a re install?

Also, I am following your guide for the Windows store removal. When I did the third step, to uninstall Spotify app, it closed and deleted my current Spotify. It seems as if it was the Windows store version, but was showing its the Windows version?

I am going to follow the rest of the guide and report back.

It seems that I somehow? had both versions installed. Even though it showed I had the Spotify for Windows version, I somehow was using a different version. Again, I don’t know how, and if anyone knows, I’d like to know myself.

It is working now. I followed the uninstall process. One note, using the 1.4.13 would freeze Spotify when I’d play any song, but 1.4.11 works.

Thanks for everything.

1 Like

Glad you got it working again. i do not believe you can have 2 versions installed at the same time, so they probably just renamed the store version.

When it comes to spotify its best not to second guess or think too hard about things… They change things around all the time for no reason and with no explaination :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.