Can't load 1.1.7 - complains about monitor programs and dsound.dll

Problem description:
Installed 1.1.7 but Spotify won’t start. First error message is “A monitor program has been found running in your system. Please unload it from memory and restart your program”. And then "Cannot find DSOUND.dll’, Please re-install this application’. Spotify then quits

Operating system:
windows 10

Soundcard:
Steinberg CI 2+

Spotify version
1.0.49.125.g72ee7853

Equalify Pro version
1.1.7

Any special software or hardware you might have installed:
Visual Studio

I have tried deleting dsound.dll from %appdata%\spotify and reinstalling, but I get the same problem. Process Monitor shows that dsound.dll is being found in that directly.

Hello, sorry about not responding sooner, I’ve not seen this post until now.

Visual studio is not a problem at all.
Most likely you have had a debugger or some other process/memory monitor/inspector running. Themida, the protection used by Spotify and Equalify, does not like that. Unfortunately its a bit random when it comes to the detection.

This post is now 4 days old, but if you haven’t already tried it, a reboot usually solves the “monitor program found” issues. Then you can just use all the programs you normally use and see if one of them trigger the protection.

Thanks for responding. As a music software developer, I’ve been bitten by Themida before… I didn’t have any active debug sessions running at that time though.

Unfortunately I’m now out of the office for a couple of weeks so I can’t easily test this yet, but I’ll try again once I’m back in.

Ok, rebooted and reinstalled. Now I get an error: “Equalify Pro Key not activated or invalid. Audio has been muted! Please make sure your license is active”.

I haven’t changed computer - it’s the same as before, and I haven’t seen any prompts asking me to re-enter the license key.

That might have been my fault i deactivated your old key since 1.1.7 uses a different key than your old EQ version did.
I forgot about the automatic upgrade of old keys.

All you need to do is log back in and it will activate and work just fine.

The activation keys were changed over a year ago for all new versions, but you did not update in that time period so you did not have a new key yet.

Great - uninstalling and reinstalling caused the login dialog to show and it’s now working again.

Thanks

Hello,

I have the same issue with same error messages. Reinstalled both spotify and equalify, worked fine about an hour but after restart it’s back to same issue again.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.