Audio Issues (no music, random pop/clicks)

help

#21

i have the same problem. Without the plugin the sound works, if i choose a preset like “rock” the sound is off like reported above.


#22

Will do, made a small video;

https://drive.google.com/open?id=1oMBc3_F1lACcppRY-Y_V1g1KOc3ji63O


#23

WOW… what on earth is that!

@andree77 is that whats happening for you too ?

I have never seen or heard the EQ behaving that way before. I honestly have no idea what is causing that. But it sounds like the tiny changes you do are multiplied by a lot and it makes the audio clip… But at the same time the analyzer does not show any noticeable changes, so that cant be it…

And it looks to be working fine when you had the EQ on, and one band at 0.0db.

Which means that the audio is going through every DSP and spitting out clean audio, but once you change it it suddenly distorts…

Did any of you get a windows update lately? driver update? What kind of CPU do you have?


#24

When i look at it again, the analyzer in the Equalify window looks “off” from the start… it shouldn’t be showing that high in the mid/high end…


#25

Yes, i have the problem you discribed. I have the problem since this morning. Yesterday everything works fine and i have no windows updates installed lately.


#26

Similair, one song was finished, followed by complete silence.
Windows updated roughly 2 weeks ago.


#27

There has been no changes to Equalify for a while, and i get Spotify updates a little while before everyone else, so i know Equalify is working with all public versions of Spotify. Something must have changed - somewhere - over night. Wonder what it can be.

It almost sounds like the math in the EQ dsp has suddenly stopped producing the correct output… Which is weird, cause that is thats true and tested math that has worked flawlessly for a decade.

If windows updated 2 weeks ago that would not be an issue, the problem would have appeared right after.


#28

Any chance you can open a command window and start up spotify like this:

Spotify.exe --show-console /dbg

then play a song, wait for all the text to stop scrolling and see if you can find something like this and paste it here:

14:07:18.831 I [audio_decompressor_process.cpp:267] Opening sink for playback.
14:07:18.831 I [audio_decompressor_process.cpp:268] codec: vorbis
14:07:18.832 I [audio_decompressor_process.cpp:269] bitrate: 320000 bits/s
14:07:18.832 I [audio_decompressor_process.cpp:270] sample rate: 44100 Hz
14:07:18.832 I [audio_decompressor_process.cpp:271] channels: 2
14:07:18.832 I [audio_decompressor_process.cpp:272] sample format: 16-bit-pcm
14:07:18.832 I [audio_decompressor_process.cpp:275] duration: 155702 ms
14:07:18.835 I [audio_decompressor_process.cpp:562] Starting playback.
14:07:18.835 I [audio_decompressor_process.cpp:564] min limit 2200 ms.
14:07:18.835 I [audio_decompressor_process.cpp:565] compressed buffer: 55337 bytes
14:07:18.835 I [audio_decompressor_process.cpp:567] decompressed buffer: 0 ms
14:07:18.835 I [audio_decompressor_process.cpp:569] sink buffer: 1021 ms
14:07:18.835 I [audio_decompressor_process.cpp:570] final source buffer: false
14:07:18.836 I [audio_player_queue_entry.cpp:317] Entry (1565E610) is not buffering


#29

https://pastebin.com/XGXteeGw


#30

I’m experiencing the same problem here, I don’t remember having any windows updates recently however, and the problem very suddenly arose in the middle of listening to a track a few minutes ago!
Something odd I’ve just noticed is the only way to get sound back with equalify set on is to press ‘Reset’, I just tried changing the gain, both up and down, to see if that was affected too and the issue persisted even after manually setting the gain back to 0, just to a lesser extent.


#31

@Datlisk Can you please do the console log thing that i explained above ?

I think i might have found one thing that could cause an issue. would be nice with a second sample!


#32

https://pastebin.com/VFz4NL87

Here you are! I think what you’re looking for is near the bottom.


#33

Thank you! That gives me hope, cause i’m seeing the exact same thing in your log file.

Looks like Spotify is experimenting with different sample formats for the audio. The format they have been using since 2008 is 16bit integer PCM.

In both of your log files it looks like they are testing out 32bit float PCM, wich will allow for better quality audio, but Equalify cant deal with. That would explain why things get corrupted as soon as you try to change anything, But i dont understand why it doesnt corrupt the audio the whole time.

Unfortunately i do not seem to have any Spotify account that has been flagged for that 32bit sample test… So i’m not able to test this myself…so that is a problem…


#34

could you try to play a few different songs in different albums and different ages then provide the same log file


#35

https://pastebin.com/ju97jjis
Gorillaz’s newest song from a few days ago


#36

https://pastebin.com/HzehEQDC
Gloria’s Step - Bill Evans Trio from Sunday at the Villiage Vanguard, 1961.


#37

Thank you!
It shows the same as the other log, which is good!

I’m working on a fix as we speak! Might need help testing it later, since i can not replicate the issue on my side.


#38

Okay, I’ll keep an eye out on my messages for if you need anything then!


#39

@Datlisk @andree77 @MrJDucky @Wilza

A fix has been made (it works on one machine at least)…

If you could test it that would be great!


#40

The file works :slight_smile: My problem is solved